Tutorial: Open a model to browse



Release:

4.6  •  5.0  •  5.1  •  5.2  •  5.3  •  5.4  •  6.0  •  6.1  •  6.2  •  6.3  •  6.4  •  6.5


This simple tutorial shows you how to explore a small Analytica model.


It will help you get a feel for how Analytica works!


Open the Rent vs. Buy model

Follow these steps:

  1. You start Analytica like any Windows application: For example, click the Start button on the Windows taskbar. Click All AppsAnalytica 6.4Analytica 6.4.
    Launch Ana6.4 from Start Menu.png
  2. After Analytica starts,

select the Rent vs. Buy Example on the Intro screen.


Open Buy vs Rent Example6.4.png


Click the Rent vs Buy
example model

The Diagram window

When you open a model, Analytica first displays a top-level Diagram window. A diagram is a graphical user interface that displays user inputs and outputs, influence diagrams, pictures, and other visual elements and controls, and is designed by the author of the model. The Rent vs. Buy model diagram shows several input variables that affect the trade-offs between renting and buying, Normal distribution buttons, a Calc button, and a node labeled Model.

Chapter 1.3v2.png


User input


Normal distrib. button


Calc button to see results


Model node

This top-level diagram is an end-user interface to the model itself, which is contained in the Model node. In this chapter, you use only the interface in this top level diagram; in the following chapters you will explore the model in more depth.

Across the top of the screen is a horizontal palette of buttons. This is called the tools palette.

BrowseToolOnToolbar5.0.png


The browse tool

When you first open the Rent vs. Buy model, the browse tool is highlighted on the palette. With the browse tool selected, the cursor looks like a hand Chapter 1.5.png when it is over the diagram. The browse tool allows you to calculate the model, change input values, and examine — but not change — the structure of the model.

Access Help Resources

At any time, you can press the F1 key on the keyboard or use the Help menu to access Analytica’s help resources online. This menu includes links to this Tutorial, the User Guide and much more tips and reference material on this Analytica Wiki.

Compute output values

In the Rent vs. Buy model, the output value of interest is at the bottom, Present value of buying and renting.

Chapter 1.3v2.png


1.  Click the Calc button to compare the present value of buying and renting.

The output value displays in a Result window. This Result window shows a graph of two probability density curves, one for buying and one for renting. In a probability density graph, the units of the vertical scale are chosen so that the total area under each curve is 1 (100%). 25μ corresponds to 25 x 10-6 or 0.000025.

Tip
Numerical suffixes like μ and K are used extensively throughout Analytica. A quick reference for these suffixes is given in Number formats .
Chapter 1.7v2.png

Since the graph is of probability densities, both buying and renting have probabilistic, or uncertain, inputs. The probability density graph for each appear to be bell-shaped curves (normal distribution), although they appear a bit “noisy.”

The graphs show that the cost of renting, given the model’s inputs, are between about $105,000 and $155,000 (the negative numbers mean cost — cash flowing out), while the cost of buying is between $115,000 and a gain of $75,000.

Chapter 1.8v2.png


2.  Click the Diagram window to bring it to the front.

Note: Your results can vary slightly, since the model is generating random inputs based on a normal distribution for the uncertainty of the rate of inflation and for the appreciation rate.

Click the model Diagram window to bring it to the front. Notice that the button next to Costs of buying and renting has changed to Result. The Result button indicates that the value has been computed; clicking the Result button re-displays the computed values.

Chapter 1.9v2.png


The Calc button has changed to Result.

Examine definition types in user input nodes

When you enter a value into a user input, you need to enter a value that is compatible with it's definition type. See more here...Expression popup menu.

Click the Time horizon node.
Press F4 to bring up the object window.

Chapter1 8av2.png


1.  Click the Variable Time horizon, then press F4.

Press F9 to enter edit mode (otherwise the expression popup menu is disabled).

Click on the Expression popup menu (here it has a numeric icon, since this input is restricted to numbers only).
Note that Number only is selected. If you attempt enter text into the input node you will get a warning.

Chapter1 8bv2.png


2.  Click on the Expression popup menu - Note that Number only is selected.

Press F8 to go back to Browse mode.

Close the object window - click the object window icon at the top left of the object window and select Close from the popup menu.

Chapter1 8cv2.png


3.  Click on the Object window icon.


4.  Select Close.

Change input values and recompute results

Now you will change some input values to the model and recompute the rent vs. buy comparison. You will change the values of Time horizon, Monthly rent, and Buying price.

Chapter 1.9v2.png


1.  Click the box next to Time horizon. Change the value to 7 and press Alt+Enter.
Tip
The main Enter key and the numeric keypad Enter key are not interchangeable. They have different functions in Analytica. Alt+Enter is equivalent to the numeric keypad Enter key.

As soon as you change an input, the Result button changes to a Calc button, indicating that Present value of buying and renting needs to be recomputed.

Chapter 1.10v2.png


2.  Click the box next to Monthly rent. Change the value to 1400 and press Alt+Enter.
Chapter 1.11v2.png


3.  Click the box next to Buying price. Change the value to 180K (or 180000) and press Alt+Enter.

Now you are ready to recompute to see the new results.


The graphs show that the cost of renting, given these changed inputs, is between $90,000 and $120,000, while the cost of buying is between $135,000 and a gain of $70,000.

Chapter 1.13v2.png


4.  Click the Diagram window to bring it to the front.

Save your model

If you want to save changes to your model, you can do so at this point. (For instructions on quitting without saving, see the next section).

Since the Analytica folder in Program files is not writable by default to a non admin user, you have to be running Analytica as an admin to be able to save over the original model file.


Chapter 1.30.png


Click Save from the File menu.

If you wish to save your model as a different file, so that you do not change the original model, select Save As from the File menu.

Quit Analytica

When you have finished using a model, you might want to quit Analytica.


Chapter 1.33.png


Click Exit from the File menu.

Summary

You have now opened an Analytica model, calculated and viewed the results, changes input values and probability distributions, and displayed the uncertain results in several ways. These are the basic techniques for using any quantitative model.

After you create your own models, you might want to give them a top-level input and output diagram like the one used in this chapter. For information about customizing a model for end users, see Creating Interfaces for End Users in the Analytica User Guide.

The next Tutorial page, shows how to navigate the details of the Rent vs. Buy model, exploring its structure and contents.

Notes


See Also


Comments


You are not allowed to post comments.